Cycle - Problems with password containing special characters

Hi Team.

I will try to explain what happens to me with Cycle.

I use “.conf” to manage the credentials in the project.
This file is not shared in the project since it is discarded in “gitignore”

The problem occurs when certain special characters used by my client to generate passwords are used.
These are the special characters I’ve had problems with: ! # $ , : ?

In some cases, it returns an error in which it proposes to use a file with the extension “.properties” instead of the “.conf” configuration file.

image

Since I haven’t found anything in the Cycle 2.9 documentation, my question is the following.

  • What are the implications of using the “.properties” extension instead of “.conf”?

  • Can we opt with this extension to the same options that it provides in the “.conf” file?

Thanks in advance.

1 Like

Fernando,

I have included additional information regarding the special characters in .conf files in the Customer Care help desk ticket that you submitted. I wanted to post my findings in this community thread in case any other Cycle users are running into the same issue with special characters in .conf files.

I found that enclosing the values with special characters within double quotes allows the Cycle step to properly parse the file and assign the values to variables.

Example:
password = “passwor#d”

I am still looking at the implications of using the .properties file extension and will post those findings here as well once I have finished my investigation.

This is a good reference for the syntax for the .conf files:

HOCON

Unquoted strings are used literally, they do not support any kind of escaping. Quoted strings may always be used as an alternative when you need to write a character that is not permitted in an unquoted string.