Using "<" when combining

I’m trying to construct <ASSET_TYP>1</ASSET_TYP> as a complete string to be able to validate something. Like so :

Feature: My Feature
And I assign “1” to variable “KAR_TYPE”
And I assign variable “check_string” by combining “<ASSET_TYP>” $KAR_TYPE “</ASSET_TYP>”
Then I echo $check_string

Unfortunately this doesn’t work :

I’m missing the </ASSET_TYP> part at the end.

It has to do with the use of the “<” within inside of the final string I try to combine here.
If I leave it out

Feature: My Feature
And I assign “1” to variable “KAR_TYPE”
And I assign variable “check_string” by combining “<ASSET_TYP>” $KAR_TYPE “/ASSET_TYP>”
Then I echo $check_string

Then I get my third string combined with the first 2 but is not usable for me without the “<” added

How can I create <ASSET_TYP>1</ASSET_TYP> as a single string ?


It might be that the output pane in Cycle is not sure how to properly display that XML and the output might be misleading us. I would suggest as a next step to load that string in via another means (read it in from a text file or from a web service or database) and use an “I verify” step to check to see if the check_string does in fact contain what you think it might. In other words, it might be working, but it could be displaying strange.

You could also try running that feature from cycle-cli on the command line to inspect the output to rule out the output in Cycle’s UI as the problem.

Let me know how it goes!

1 Like


I do believe Evan’s suspicion that the output pane is not properly displaying the XML may be the root cause of your issue.

I ran a simple test and was able to confirm that the variable does appear to be assigned correctly in CSV output.

I also noticed that the default web report does not appear to display XML output properly, similar to the output pane.


@Art.Smith @Evan

I can confirm your suggestions regarding this issue. Both report as well as the
output pane do not display this ‘combined’ variable correctly.
If performed a positive test using <ASSET_TYP>1</ASSET_TYP>
as well as a negative test using <ASSET_TYP>1/ASSET_TYP>

I am certain my actual validation test is executed using the full combined string, so that is good.

Will you start a fix for this ‘display in report’ and ‘display in output pane’ issue ?

1 Like

Thank you for confirming John.

I will submit this issue as feedback to our product development team so they can get it added to their work item list.

1 Like

Which version of Cycle did you verify the issue on @Art.Smith ?

@SethTarrants Cycle 2.9.2


I have news regarding this issue you reported. Our upcoming release of Cycle 2.10 due to release later this month addresses the problem of properly displaying XML in Cycle output and HTML reports.

Cycle 2.10 is currently being tested in preparation for release. You should see an announcement about the release in the next couple of weeks.

I did test the fix for the issue using the example you provided, and I can confirm the XML does display properly in both the Cycle output as well as the HTML report.

1 Like

Art, all, thanks for this excellent follow up !

@JohnM Just to confirm what @Art.Smith said, if you log into Cycle Cloud, you can download the latest release - Cycle 2.10 - which includes this bug fix. We’ve also put down some groundwork that improves group testing performance, and will enable us to improve performance even more in the future.

Thanks for reporting this issue! Once you start using Cycle 2.10, let us know what you think - we love hearing from you. You give us such useful feedback!

@Jillian.Ketterer , @Art.Smith Finally got around to installing 2.10.

So far so good, I haven’t zoomed in on the above mentioned issue and fix but I will let you know